Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Grub issue not booting ?
#1
Hey all...

[Image: FlfFJ0o.png]

Below fix applies to following error too :
>> symbol grub_is_shim_lock_enabled not found" error <<

In case you are one of the affected people, below is how you can fix the issue. I have tested it and it works fine. And keep in mind that XeroLinux is basically ArchLinux so below fix will work on Arch as well as any Arch-Based distros with the exception of Manjaro that is NOT Arch... Read more on that >> Here <<

- Disclaimer :

Below guide covers EXT4/XFS/BTRFS Unencrypted Filesystems, for Encrypted Drives, you will have to either "Google it" lol, or check at the bottom of this guide where I posted a link to EndeavourOS' more advanced guide for Chrooting into your system... There are 2 options if first one works no need for the rest, and so on...

Anyway here's what to do...

- Mount your system to work in..

First of all boot using Arch or XeroLinux Live boot USB and follow below...

The device or partition with your Linux system on it will need to be mounted. To discover the kernel name of the storage device name, type:

sudo fdisk -l

Mount the device or partition : (replace "sdXn" with your Actual partition name)

[Image: SZO4qw0.png]

For EXT4 & XFS

sudo mount /dev/sdXn /mnt (Linux Filesystem)
sudo mount /dev/sdXn /mnt/boot/efi (EFI System)

For BTRFS

sudo mount -o subvol=@ /dev/sdXn /mnt (Linux Filesystem)
sudo mount -o subvol=@ /dev/sdXn /mnt/boot/efi (EFI System)

- Chroot into your system :

With this information, you are able to arch-chroot, and to be able to do that you need to have root permissions, so type the following command:

sudo arch-chroot /mnt

- Fix Grub boot loop issue :

Now you’ve chrooted into your installed system, and you are able to access your files, install packages, or alter scripts to rescue your system. to fix Grub run this in chroot...

sudo grub-install --removable --target=x86_64-efi --efi-directory=/boot/efi --disable-shim-lock

[Image: dfBQw4X.jpeg]

This will install grub on persistent memory as opposed to volatile one... By default Grub will sit on volatile memory, I dunno why, and since when devs decided to do that, suffice it to say that whatever the reason behind this was below command will fix you right up...

then update grub via below command

sudo grub-mkconfig -o /boot/grub/grub.cfg

Exit arch-chroot via exit command then unmount your system n boot...

sudo umount /mnt/boot/efi
sudo umount /mnt


Thanks Wink
~ XeroLinux Toolkit Maintainer ~
I do try to help where I can, when I can.
I do this on my own, so I might not have all the answers.
[Image: K7U76Mv.png]
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Switch from Grub to Systemd-boot DarkXero 0 1,828 09-03-2022, 04:59 PM
Last Post: DarkXero
  Boot with Grub via rEFInd any other partitions and iso's cristina223 0 1,982 04-19-2022, 02:10 PM
Last Post: cristina223
Video vmlinuz-linux not found issue ? How to fix DarkXero 0 2,671 03-29-2022, 11:43 AM
Last Post: DarkXero
  Facing issue, with Bluetooth ? DarkXero 0 1,513 03-22-2022, 02:42 PM
Last Post: DarkXero
Information TimeShift AutoSnap & GRUB-BTRFS DarkXero 0 1,443 11-23-2021, 10:16 PM
Last Post: DarkXero
Information [Video] Dual-Booting Windows 10/11 & Linux DarkXero 0 4,635 11-23-2021, 03:10 PM
Last Post: DarkXero

Forum Jump:


Users browsing this thread: 1 Guest(s)